Podporujeme PHP 8.0 (stable)

Vývojáři PHP vydali novou verzi PHP 8.0.0 dle plánu 26.11.2020.

Co nového nová verze PHP 8.0 přináší, naleznete na webu https://www.php.net/releases/8.0/en.php. Zajímavé jsou zejména funkce JIT compiler, union typy, atributy a lepší práci s exception.

K této verzi byla vydána i příručka pro přechod z předchozí verze PHP 7.4.

Kompletní přehled novinek v PHP 8.0 sepsal na svém blogu Jan Barášek.

To důležité ovšem je, že WP Hosting podporuje PHP 8.0 na všech webových serverech u všech tarifů a i na VMS serverech.

PHP 8 máme ve stejné skladbě jako u předchozích verzí, které u nás znáte. Tedy s podporou imagick, GD knihovna s podporou webp, podpora brotli a mnoho dalšího. Všechny rozšíření v posledních dostupných verzích.

Co to přinese WordPressu?

„WordPress Core si klade za cíl být kompatibilní s PHP 8.0 ve verzi WordPress 5.6 (aktuálně plánováno na 8. prosince 2020).

Pro WordPress je PHP 8.0  však hlavní aktualizací verze s velkým počtem změn, které narušují zpětnou kompatibilitu, a mnoho funkcí, které byly v rámci vydání funkcí PHP 7.x zastaralé, byly oficiálně odstraněny.“ (pokračování)

Co to znamená pro uživatele WordPressu?

Blíží se další velká aktualizace WordPress 5.6 (aktuální verze k 26.11.2020 je 5.5.3), která bude ready pro PHP 8. Ovšem nelze garantovat 100% funkčnost celého ekosystému WP. S tímto bude nutné otestovat bezproblémový přechod na novou verzi PHP 8 v každé sestavě WordPress stránek, zejména bude riziko u šablon a pluginů o které se vývojáři už nestarají. Pro některé weby to bude znamenat problém a nemožnost aktualizace.

Nezkušeným uživatelům doporučujeme vyčkat několik dní po vydání nové verze WordPressu než se opraví nově nalezené chyby a zároveň budou mít i prográmatoři pluginů a šablon připravit nové aktualizace pro novou verzi WordPressu.

Současně je třeba připomenout, že o WordPress weby je třeba se starat. Aktualizovat jádro, šablony a pluginy. Souvisí s tím i nutnost aktualizovat verze PHP na podporované verze PHP.

Verze PHP 7.0,7.1 již nedostávají aktualizace od vývojářů php. Pokud některou z těchto verzí používáte, je na čase se zamyslet nad aktualizací a současně prověření, zda web bude fungovat i na novějších verzích PHP 7.2 / 7.3 / 7.4.

WordPress si sám řekne, že používáte starou verzi PHP. Změnu verze PHP provedete z administrace hostingu či na požadavek u podpory.

Aktuálně je možné u WP Hosting provozovat WordPress na verzích PHP 7.0,7.1,7.2,7.3,7.4,8.0.

PHP 7.4 je u nás stále výchozí verzí php.

Doporučení na závěr

Než se pustíte do experimentování s aktualizací verze PHP či WordPressu, myslete na to, že se může něco pokazit. Vhodné je otestovat si aktualizace bokem od produkčního webu na testovací verzi nebo si minimálně vytvořit zálohu pro rychlou obnovu.

Související články

Další novinky